Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Panorama Community. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 13. Mai 2015, 17:38

PTGui stitcht nicht wo ich will

Vermutlich ein Anfängerproblem, automatisch gestitcht sah's noch schlimmer aus, also setzte ich manuelle Control Points - wieso bringt PTGui die Teilbilder selbst damit nicht zur Deckung?

Fragliche Stelle:



Zuvor gesetzte Control Points:



Es gibt in der ganzen Murmel noch etlich ähnliche "Verwerfungen", auch horizontale. Wie bringe ich PTGui dazu die Control Points zur Deckung zu bringen?
leave nothing but footprints, take nothing but memories - - Meine Website

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wus« (13. Mai 2015, 17:44)


2

Mittwoch, 13. Mai 2015, 17:43

Hast Du nach dem Setzen der Kontrollpunkte mal F5 gedrückt? (Das ist das selbe als wenn Du im Optimizer "Optimize" drückst.)
In Deiner Kontrollpunktliste ist die Spalte "Distance" nämlich noch leer, so dass Du gar nicht sehen kannst, welche Qualität Deine Punkte haben.
Einfach F5...
Gruß vom pano-toffel

3

Mittwoch, 13. Mai 2015, 17:47

Nein, ich dachte wenn man die Punkte manuell setzt soll man das nicht machen? Dachte dann wirft PTGui meine mühsam - und bei 100% mit maximaler Präzision - gesetzen Control Points wieder durcheinander?

Ich werd's gleich mal probieren.
leave nothing but footprints, take nothing but memories - - Meine Website

4

Mittwoch, 13. Mai 2015, 18:02

So jetzt habe ich den Optimizer laufen lassen, das Ergebnis ist aber eher schlechter als vorher - der Versatz an der Dachrinne ist immer noch da, zusätzlich ein horizontaler links von dem Frisörschild.



Habe ich noch was vergessen / übersehen?
leave nothing but footprints, take nothing but memories - - Meine Website

5

Mittwoch, 13. Mai 2015, 18:11

Vermutlich ein Anfängerproblem,
Ja, das PTGui mit jedem Anfänger so. Aber Du wirst dieses Software-Juwel noch lieben lernen. :-)

Zitat

automatisch gestitcht sah's noch schlimmer aus,
Das kann sein. Es gibt Fenster in der Fassade, die sich ziemlich ähnlich sehen. Bei der ersten Erkennung werden Pixelmuster verglichen, und da liegt es in der Natur der Sache, dass auch eine Software sich von einem Raster täuschen lassen kann. Der erste Weg wäre, diese Kontrollpunkte ausfindig zu machen, zu löschen und neu zu optimieren. In der Spalte "Distance" bekommst Du eine Info, wie viele Pixel weit sich jeder Punkt vom Sollwert entfernt befindet. Einzelne Ausreißerpunkte erkennt man an hohen Werten. Jeder Kontrollpunkt "zerrt" das Bild in eine Richtung, die ihm zugute kommt, so dass die Summe aller Abweichungen möglichst gering bleibt. Jeder Kontrollpunkt hat also eine gewisse "Zugkraft", die sich auf die Lage des Bildes auswirkt. Wenn es nur einen sehr schlechten Punkt unter hundert guten gibt, dann ist seine Auswirkung nur gering, und das wird man am Distance-Wert eindeutig ablesen können. Wenn es jedoch nur wenige Kontrollpunkte innerhalb einer Überlappung gibt, dann ist der Einfluss eines einzelnen Punktes verhältnismäßig groß. Wenn der nun kräftig am Bild zerrt, werden die wenigen anderen Punkte viel deutlicher daneben liegen, so dass man am Distance-Wert manchmal nicht eindeutig erkennen kann, welcher genau der Übeltäter ist. An dieser Stelle ist "brain" gefragt, und nicht das blinde Löschen aller ach so schlechten Punkte. Wenn der Übeltäter optisch entlarvt und dann entfernt wurde, verbessern sich die anderen Werte nach F5 schlagartig.

Wenn man dieses Prinzip begriffen hat, ist es relativ einfach, gute Ergebnisse zu stitchen.
Das nächste Problem ist, dass manuelle Punkte den Anwender manchmal täuschen können, denn wie Du in Deinen Beispielbildern schon siehst, kann das selbe Motiv am Bildrand total anders verzerrt sein als beim Nachbarbild nahe dem Zentrum. Manuell liegt man schnell mal ein paar Pixel daneben. Wenn zwei Bilder mit rein manuellen Punkten nicht ganz sauber zusammenpassen, zieht man in einem der Bilder einen Rahmen auf (das geht mit der Maus bei gedrückter Umschalttaste). Mit einem Rechtsklick in diesen Rahmen kann man in diesem Bereich gezielt Kontrollpunkte suchen lassen, die meistens genauer sind als die manuellen. Die Bestätigung kann man nach dem Drücken von F5 in der Distance-Spalte ablesen, und die kleinen Ausreißer löschen, bevor man nochmals optimiert.

Zitat

also setzte ich manuelle Control Points - wieso bringt PTGui die Teilbilder selbst damit nicht zur Deckung?
Die Antwort heißt: F5 ;-)


Wenn Du diesen Text nicht beim ersten Mal verstehst, dann lies ihn bitte so oft, bis Du es hast. Probiere jeden Schritt aus, und beobachte genau, wie PTGui darauf reagiert. Ich kann nur sagen: PTGui ist sanft und gutmütig.
Gruß vom pano-toffel

6

Mittwoch, 13. Mai 2015, 18:20

So jetzt habe ich den Optimizer laufen lassen, das Ergebnis ist aber eher schlechter als vorher...
Das kann verschiedene Ursachen haben. Eine der häufigsten ist, dass die Brennweite beim Fotografieren aus versehen gezoomt wurde. Das musst Du ausschließen können. Eine andere Ursache kann sein, dass der Drehpunkt nicht sauber eingestellt ist, aber das sieht man nur bei Bildern, die Kontrollpunkte auf nahen Vordergrund- und weiten Hintergrundmotiven haben. In dem Fall sind alle Kontrollpunkte im Vordergrund manuell zu löschen. Danach passt der Hintergrund, und vorne ist Retusche angesagt.
Ein weiterer Grund kann sein, dass ein Bild nicht nur Kontrollpunkte zu seinem direkten Nachbarn hat, sondern auch zum übernächsten oder zum Bild darüber oder darunter. Wenn dort etwas nicht stimmt, dann können immer noch falsche Punkte an diesem Bild zerren. Man muss die CPs immer global im Auge behalten. Dafür gibt es unter den Tools eine Kontrollpunktliste, die alle Punkte aus dem Pano anzeigt. Dort müssten bei Dir die Ausreißer gleich auffallen.
Das Problem kann natürlich auch anders herum sein, dass man so viele schlechte Punkte gelöscht hat, dass manche Bilder gar keine CPs mehr zu ihren Nachbarn haben, dann muss man dort eben neue erzeugen.
Gruß vom pano-toffel

7

Mittwoch, 13. Mai 2015, 18:35

Im Optimizer kannst Du gezielt schalten, welche Bilder beim Optimieren überhaupt berücksichtigt werden sollen. Die globalen Haken an der linken Seite sollen dabei am besten aus sein. In der rechten Spalte kannst Du die Bilder wählen, deren Kontrollpunkte in die Berechnung einfließen sollen, und im mittleren großen Schaltfeld kannst Du erlauben, welche Bilder auf welche Art bewegt werden dürfen.
Wenn Du rechts nur die beiden auswählst, die Du hier gezeigt hast, dann mit F5 optimierst, sollten die beiden einwandfrei passen. Wenn sie bei globaler Berechnung wieder nicht passen, liegt der Fehler nicht an den Punkten, die diese beiden Bilder gemeinsam haben, sondern Du musst bei den Nachbarn suchen.

In der Regel lösche ich alle Kontrollpunkte, die ein Bild mit den übernächsten Nachbarn hat, und behalte immer nur die Punkte zu den direkten Nachbarn.
Beispiel: Du hast die Bilder Nr. 0, 1, 2, 3, 4 und 5 nebeneinander aufgenommen. Geh in den Kontrollpunkteditor, und klicke auf der linken Seite das Bild 0 an. Jetzt siehst Du im rechten Fenster, welche Reiter in Fettschrift gedruckt sind, das sind genau die, die mit Bild 0 gemeinsame Punkte haben. Bild 1 sollte unbedingt dabei sein, aber Bild 2 und 3 sollten unbedingt NICHT dabei sein. Falls doch, wähle diese Paarung, und lösche alle Kontrollpunkte, die unter den Bildern angezeigt werden. Falls Du 360° aufgenommen hast, bedenke, dass das erste Bild CPs zum letzten braucht. Wenn Du mehrere Reihen in der Höhe aufgenommen hast, dann gehe mit diesen Bildern nach der selben Logik vor. Wenn die überflüssigen Verbindungen alle sauber gelöscht sind, sollte das F5-Ergebnis schon besser ausfallen. Und jetzt kommt das Aussieben der Ausreißer, was oben beschrieben steht.

Und dann kommen immer noch ein paar Feinheiten, aber dazu später... ;-)
Gruß vom pano-toffel

8

Mittwoch, 13. Mai 2015, 18:47

Vielen Dank für Deine ausführliche Antwort.

Es gibt Fenster in der Fassade, die sich ziemlich ähnlich sehen. Bei der ersten Erkennung werden Pixelmuster verglichen, und da liegt es in der Natur der Sache, dass auch eine Software sich von einem Raster täuschen lassen kann.
Soweit klar, deshalb bin ich ja dann zu manuellem Setzen der Control Points übergegangen.

Der erste Weg wäre, diese Kontrollpunkte ausfindig zu machen, zu löschen und neu zu optimieren.
Das habe ich gemacht. Hat bei anderen Panos auch funktioniert, hier jedoch nicht.

In der Spalte "Distance" bekommst Du eine Info, wie viele Pixel weit sich jeder Punkt vom Sollwert entfernt befindet. Einzelne Ausreißerpunkte erkennt man an hohen Werten. Jeder Kontrollpunkt "zerrt" das Bild in eine Richtung, die ihm zugute kommt, so dass die Summe aller Abweichungen möglichst gering bleibt. Jeder Kontrollpunkt hat also eine gewisse "Zugkraft", die sich auf die Lage des Bildes auswirkt. Wenn es nur einen sehr schlechten Punkt unter hundert guten gibt, dann ist seine Auswirkung nur gering, und das wird man am Distance-Wert eindeutig ablesen können. Wenn es jedoch nur wenige Kontrollpunkte innerhalb einer Überlappung gibt, dann ist der Einfluss eines einzelnen Punktes verhältnismäßig groß. Wenn der nun kräftig am Bild zerrt, werden die wenigen anderen Punkte viel deutlicher daneben liegen, so dass man am Distance-Wert manchmal nicht eindeutig erkennen kann, welcher genau der Übeltäter ist. An dieser Stelle ist "brain" gefragt, und nicht das blinde Löschen aller ach so schlechten Punkte. Wenn der Übeltäter optisch entlarvt und dann entfernt wurde, verbessern sich die anderen Werte nach F5 schlagartig.
Es gab keine solchen Übeltäter mehr! Keinen einzigen, ich hab's wieder und wieder überprüft! Ich sitze an diesem Pano ungelogen schon 6 Stunden!

Wenn man dieses Prinzip begriffen hat, ist es relativ einfach, gute Ergebnisse zu stitchen.
Ich fürchte irgend ein wesentliches Detail habe ich noch nicht verstanden.

Das nächste Problem ist, dass manuelle Punkte den Anwender manchmal täuschen können, denn wie Du in Deinen Beispielbildern schon siehst, kann das selbe Motiv am Bildrand total anders verzerrt sein als beim Nachbarbild nahe dem Zentrum. Manuell liegt man schnell mal ein paar Pixel daneben.
Ein paar Pixel wären ja noch o.k., hier sind es aber schon mehr als nur ein paar - jedenfalls mit Sicherheit ein Vielfaches der Genauigkeit mit dem ich die Punkte gesetzt habe.

Wenn zwei Bilder mit rein manuellen Punkten nicht ganz sauber zusammenpassen, zieht man in einem der Bilder einen Rahmen auf (das geht mit der Maus bei gedrückter Umschalttaste). Mit einem Rechtsklick in diesen Rahmen kann man in diesem Bereich gezielt Kontrollpunkte suchen lassen, die meistens genauer sind als die manuellen. Die Bestätigung kann man nach dem Drücken von F5 in der Distance-Spalte ablesen, und die kleinen Ausreißer löschen, bevor man nochmals optimiert.
Danke für diesen Tipp, das kannte ich noch nicht und hab's gleich mal ausprobiert. Funktionierte soweit auch gut, jedoch war das beste Ergebnis das mir der Optimizer zeigte "not so good". Auch nach mehrmaligem F5 und Rauslöschen der Punkte mit größeren Distanzen. Ein paar müssen ja immer drin bleiben. Die habe ich mir auch angeschaut (wieder bei 100%) und sie saßen auch zweifelsfrei an den gleichen Stellen (bis vielleicht auf ein paar wenige Pixel hin oder her)

Das Ergebnis ist das gleiche wie vorher. Ich bin echt fruistriert und werde es jetzt für heute bleiben lassen.
leave nothing but footprints, take nothing but memories - - Meine Website

9

Mittwoch, 13. Mai 2015, 18:54

Nein, ich dachte wenn man die Punkte manuell setzt soll man das nicht machen? Dachte dann wirft PTGui meine mühsam - und bei 100% mit maximaler Präzision - gesetzten Control Points wieder durcheinander?
Optimieren MUSS man immer, wenn sich die Ausrichtung der Bilder ändern soll.
PTGui wirft auch keine CPs durcheinander. Jeder Punkt behält immer seine einmal definierte Position innerhalb des Bildes. Optimiert wird immer nur die Lage des Bildes im Verhältnis zu den anderen Bildern. Also keine Angst, Deine 100%-Präzision bleibt erhalten. Wie ich aber schon beschrieben hatte, sind diese 100% manchmal nicht so präzise. Das kommt durch die unterschiedlichen Perspektiven, wie ein Motiv abgebildet wird, aber es kann auch durch unterschiedliche Bildschärfen entstehen. Was in der Bildmitte klar und deutlich ist, kann am Rand verschwommen sein, und schon ist die Präzision dahin. Schuld sein kann die allgemein schlechtere Abbildungsqualität am Bildrand, oft sind es aber die Farbverschiebungen der CAs. Aus diesem Grund ist es wichtig, die RAWs vor dem Stitchen sauber zu entwickeln, und die CAs so gut wie möglich zu entfernen. Die Motivkanten werden schärfer, sind besser zu stitchen und sehen im Pano besser aus.
Gruß vom pano-toffel

10

Mittwoch, 13. Mai 2015, 19:01

Die Genauigkeit der manuellen Punkte kann man übrigens sehr fein steuern. In den Optionen kann man die Lupenstufe und die Bereichsgröße einstellen, die rund um die manuellen Punkte angezeigt wird. Die Größe stelle ich gerne auch größer als 100%. Man muss die Punkte auch nicht mit der Maus ganz genau anfahren, denn manche Maus ist so empfindlich eingestellt, dass sie ungewollt um ein Stückchen verrutscht. Während man die Maustaste gedrückt hat, kann man mit den Pfeiltasten der Tastatur einen Punkt pixelgenau ansteuern. Gesetzt wird er, sobald man die Maustaste loslässt. Im Zweifel kann man die Maus dazu anheben, so dass sie den Punkt garantiert nicht mehr bewegen kann.
Gruß vom pano-toffel

11

Mittwoch, 13. Mai 2015, 19:04

Das Ergebnis ist das gleiche wie vorher. Ich bin echt fruistriert und werde es jetzt für heute bleiben lassen.
Mein Tipp: Brennweite verrutscht. Oder hast Du nicht mit Zoom aufgenommen?
Gruß vom pano-toffel

Ronald

Profi-User

Beiträge: 208

Wohnort: Naumburg

Beruf: Sozialpädagoge

  • Nachricht senden

12

Mittwoch, 13. Mai 2015, 19:11

Stitching mit PTGUI

Hallo Wus,
pano-toffel als PTGUI Profi hat sich richtig Mühe gegeben. Dennoch möchte ich hier auf einen Beitrag im Forumhinweisen, der meines Erachtens deutlich macht, dass AutoPano Gigaohne manuelle Eingriffe deutlich bessere Ergebnisse beim Stitching erzielt, als PTGUI.
Ich will gar nicht auf eine BESER-SCHLECHTER Diskussion hinaus. Dennoch möchte ich sagen, dass ich mit PTGUI begonnen habe und dann doch bei APG geblieben bin. Du solltest es mal ausprobieren.
LG, Ro
Fotografieren ist wie malen mit Licht.

Intel Core i9-9900k bei 4500 Ghz - 32 GB RAM - NVMe SSD 970
APG 4.2.3
Panotour Pro 2.5.14
PS CS 5
LR 6

Ronald

Profi-User

Beiträge: 208

Wohnort: Naumburg

Beruf: Sozialpädagoge

  • Nachricht senden

13

Mittwoch, 13. Mai 2015, 19:13

Stitching mit PTGUI

...oder lass mir mal deine Bilder zukommen und ich stitche sie mal in APG und Du wirst sehen und kannst entscheiden, ob es besser gelaufen ist, als mit PTGUI.
LG, Ro
Fotografieren ist wie malen mit Licht.

Intel Core i9-9900k bei 4500 Ghz - 32 GB RAM - NVMe SSD 970
APG 4.2.3
Panotour Pro 2.5.14
PS CS 5
LR 6

14

Mittwoch, 13. Mai 2015, 19:37

Ja, ich glaube, dass AutoPanoGiga ein guter Stitcher ist. Ich habe ihn als aktuelle Version nie kennen gelernt, und kann mir über seine Leistung kein Urteil erlauben.
Meine Ergebnisse in PTGui waren anfangs auch nicht so gut, aber je intensiver ich mich mit diesem Programm befasse, um so mehr bin ich davon überzeugt, dass ich gar nichts anderes mehr ausprobieren will.
Ich hätte aber Spaß daran, den Zusammenbau mit wus' Bildern ebenfalls zu probieren und über die Erfahrungen zu berichten. Unsere beiden Ergebnisse samt Erläuterungen wären sicher eine Bereicherung für die, die noch in der Software-Entscheidungsphase stecken.
Gruß vom pano-toffel

Ronald

Profi-User

Beiträge: 208

Wohnort: Naumburg

Beruf: Sozialpädagoge

  • Nachricht senden

15

Mittwoch, 13. Mai 2015, 19:44

Ptgui & Apg

Hallo Pano-Toffel,
Das wäre eine coole Idee. Also wus: her mit den Bildern.
LG, Ro
Fotografieren ist wie malen mit Licht.

Intel Core i9-9900k bei 4500 Ghz - 32 GB RAM - NVMe SSD 970
APG 4.2.3
Panotour Pro 2.5.14
PS CS 5
LR 6

16

Freitag, 15. Mai 2015, 18:29

Das ist ja ein super Angebot von euch beiden, vielen Dank dafür! Aber würdet ihr das auch immer wiederholen wenn ich mit dem nächsten Problempano daherkomme? Wohl kaum... und ich möchte auch lieber lernen selber mit PTGui klarzukommen.

Autpano Giga habe ich jetzt mal kurz ausprobiert, automatisch kriegt es diese Bilder auch nicht richtig gestitcht. Näher schaue ich mir das aber erst an wenn ich nach einiger Zeit feststellen muss dass ich mit PTGui absolut nicht klar komme. Vorläufig will ich nicht weitere Software kaufen, mir sitzt der Euro momentan nicht so locker.



Meine Vorstellung von den CPs muss ich wohl revidieren. Ich dachte PTGui bringt die zur Deckung.

Die Vergrößerung habe ich vereinzelt auch schon über 100% eingestellt, meist fand ich aber 100% ausreichend. Mein Bildschirm hat "nur" 101 ppi und ich sitze nahe genug davor um die Einzelpixel gerade noch erkennen zu können. Danke für den Tipp mit den Pfeiltasten, auch wenn ich bisher mit der Präzision meiner Maus kein Problem hatte.

Ich hatte mit Zoom aufgenommen, aber am unteren Anschlag, also 8mm. Ich habe jetzt mal die EXIF-Daten aller Fotos überprüft, die wurden alle bei 8mm gemacht. Das Sigma kriecht auch kaum, in der 8mm Stellung überhaupt nur wenn man es nach oben hält und stark schüttelt.

PTGui erkennt das Objektiv fälschlicherweise als Fisheye, aber diese Einstellung habe ich korrigiert.

Ich habe jetzt die helle Serie JPGs auf halbe Auflösung runtergerechnet und damit einen neuen Versuch gestartet. Dabei habe ich diesmal ein anderes Foto als Anker bestimmt. Die 12 Einzelbilder der Kugel ohne Boden kriegt PTGui damit nach wenigen Optimizer Runs gut gestitcht, aber sobald ich versuche das Bodenfoto einzubauen wirft es wieder alles durcheinander. Automatisch fügt es das Bodenfoto nicht ein, also habe ich händisch 3 - 4 CPs zu den angrenzenden 6 Fotos eingefügt - hilft aber nichts, das Ergebnis - ohne Optimizer - ist unbrauchbar. Wenn ich dann den Optimizer laufen lasse ist es "bad", und wenn ich mir dann den CP Table ansehe und nach Distance sortiere sind genau die Punkte zum Bodenfoto die mit den größten Distances. Wenn ich die rauslösche und neu optimiere steht das Bodenfoto nahezu wieder ohne CPs zu den angrenzenden Fotos da.

Wohin darf ich Dir die Fotos hochladen, pano-toffel? Eigenen Webspace habe ich keinen. Alle JPGs + RAWs + die zuletzt gerechneten Panos und Einstelldateien haben zusammen etwa 1,2 GB. Da ich hier nur etwa 800 kbps Upload Geschwindigkeit habe wird es ziemlich lange dauern... oder Du schreibst mir was Du minimal brauchst. Nochmal danke für das Angebot!
leave nothing but footprints, take nothing but memories - - Meine Website

17

Freitag, 15. Mai 2015, 23:09

Mache doch die jpgs in eine zip und dann hier: http://daten-transport.de/

18

Samstag, 16. Mai 2015, 00:58

Das ist ja ein super Angebot von euch beiden, vielen Dank dafür! Aber würdet ihr das auch immer wiederholen wenn ich mit dem nächsten Problempano daherkomme? Wohl kaum... und ich möchte auch lieber lernen selber mit PTGui klarzukommen.
Naja, so eine Aktion kann Mut machen, wenn man sieht, was die Software zu leisten imstande ist, auch wenn man das gerade noch nicht so kann. Ich habe mit PTGui mehrere Hundert Kugeln zusammengesetzt, und es gehorcht mir inzwischen ziemlich gut. Neulich habe ich mir nochmal einen Satz alte jps vorgenommen, die ich als PTGui-Anfänger nicht passend bekommen hatte. Ich war damals schier verzweifelt, und hatte dann mit rudimentären Retuschekenntnissen versucht, das Pano zu retten. Jetzt, im zweiten Anlauf weiß ich, an welchen Hebeln ich drücken muss, um Erfolg zu haben, wenn die Automatik mal wieder nicht das macht, was ich haben will. Früher hatte ich auch Zweifel, ob mein NPA richtig eingestellt war, und die sind mit dem passenden Pano ausgeräumt. Sie hätten sich allerdings auch bestätigen können. Je nach Motiv und Bildqualität finde ich auch auch solche Fehler, dann weißt Du, wo Du zuerst optimieren kannst.

Zitat

Meine Vorstellung von den CPs muss ich wohl revidieren. Ich dachte PTGui bringt die zur Deckung.
In gewisser Weise stimmt das ja auch. Nur die Lage der definierten Punkte zu den Pixeln eines Bildes verschiebt sich innerhalb des Bildes nie. Es wird immer das ganze Bild MIT allen CPs geschoben, gedreht, geneigt, so dass am Ende alle CPs möglichst deckungsgleich sind.

Zitat

PTGui erkennt das Objektiv fälschlicherweise als Fisheye, aber diese Einstellung habe ich korrigiert.
Das kann man in den Optionen dauerhaft verankern, wenn man ständig die gleichen Objektive nutzt. Wenn Du das 8-15 mit einem 8er Fisheye abwechselst, musst Du das in PTGui jedesmal berücksichtigen.

Zitat

... aber sobald ich versuche das Bodenfoto einzubauen wirft es wieder alles durcheinander...
Das Einsetzen eines schräg aufgenommenen Bodenbildes mit der Viewpoint-Funktion muss man nach strengen Regeln machen. Es gibt dazu eine gute Beschreibung auf der PTGui Webseite, und hier im Forum habe ich das auch schon genau beschrieben. Vielleicht findest Du das, wenn Du in meinen Beiträgen nach "Viewpoint-Funktion" suchst.
Automatisch geht da nichts, und das wäre auch nicht sinnvoll, weil es dazu "brain" braucht, um Dinge zu unterscheiden, die eine Software nicht wissen kann. Im Lauf der Bearbeitung muss man die Haken im Optimizer so setzen, dass kein Bild außer dem Nadirfoto bewegt werden darf, dann geht auch an der bisherigen Arbeit nichts kaputt. Sehr wichtig ist, dass im Nadir nur ganz bestimmte CPs gesetzt werden dürfen, nämlich genau die, die sich innerhalb einer gemeinsamen planebenen Fläche befinden. Bitte beginne bei den ersten Versuchen nicht mit einem unebenen Bodenbild, wie z.B. einer Treppe, einer Tischkante oder einer blühenden Hecke. Dann wird die Verzweiflung zu groß. Wenn man solche Motive im Nadir haben will, gelten erhöhte Anforderungen beim Fotografieren.

Zitat

Wohin darf ich Dir die Fotos hochladen, pano-toffel?
Ich nutze für sowas sehr gerne www.daten-transport.de
Dort kann man bis zu 1GB pro Datei hochladen. Das zip-Format ist gut, weil man nur eine einzelne Datei hoch- und runterladen muss.
Nach dem Hochladen wird auf der Seite ein Link erzeugt, den Du hier posten oder mir per PN senden kannst.
Ich würde empfehlen, dass Du einen Satz unverkleinerte jpgs zusammenpackst, und eventuell Deine pts-Datei (Projektdatei aus PTGui). Das sollte selbst bei hoher Auflösung unter 200 MB Gesamtvolumen bleiben. Lass es über Nacht hochladen, denn bei Deiner Uploadrate dauert das 4 Stunden. Wenn Dir das zu viel ist, schick mir eine Daten-CD oder eine SD-Card.
Als Ergebnis würde ich Dir eine neue pts-Datei zurücksenden, dann siehst Du genau, was dort alles eingestellt ist, und kannst das Pano selbst rendern lassen.
Gruß vom pano-toffel

19

Montag, 18. Mai 2015, 10:28

Endlich kann ich hier wieder weitermachen. Die JPG-ZIP steht jetzt auf http://daten-transport.de/?id=yXYUzHqC3uZG zum Download zur Verfügung.
leave nothing but footprints, take nothing but memories - - Meine Website

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wus« (18. Mai 2015, 10:57)


20

Montag, 18. Mai 2015, 14:25

Hab mir deine Bilder angesehen und mit PTGui gesticht. Das erste Ergebnis sah genau so kaputt aus wie bei dir. Mit ein wenig Ursachenforschung war der Fehler aber schnell gefunden. Dein NPA von Novoflex ragt sehr ungünstig in die untere Bildreihe und dadurch werden eine Vielzahl von völlig unsinnigen Kontrollpunkten generiert. Nach dem Löschen dieser Kontrollpunkte sieht alles anders aus und es kommt ein ordentliches Pano heraus.



Gérard

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Gérard« (18. Mai 2015, 14:32)